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Product Overview

The Special Services Application is a secured system for providing services to special education educators. The primary focus is meeting the needs of the special education educators. The Special Services system supports the following features in two modes; Form Wizard mode and PDF View in WYSIWYG format (What You See Is What You Get): Form generation, editing, printing and review. 

This system will allow users to create, maintain and view virtually any student-related document on file by your school district. These documents (forms) are stored in the ProgressBook application as Adobe PDF forms and are available to any user of ProgressBook with the proper security role and system requirements.

Since the Special Services application is a combination of three technologies (Operating System, Browser Version, and Adobe Version), there are certain nuances with each combination. It is recommended that a user always uses the highest version of the Browser that is supported on the Operating System in use. The following table provides recommendations of Adobe Versions on each operating system for the most effective use of the Special Services application. One final note, users on a “broadband” service (DSL or Cable Modem) will have a much more responsive experience working within a Forms environment from home.

Software Requirements

All systems requirements are addressed in the ProgressBook Special Services Systems Requirements document.  Please review this document for specifications.

Special Services no longer uses DSNs with this release forward.  Please edit the Web.config file on the Web server located in the root of the Special Services folder.  The following should be in the web.config file:

<add key="PBMasterCn" value="data source=YOURSERVERNAME;initial catalog=pb_master;password=pbadmin;persist security info=True;user id=pbadmin;"/>

Please make sure that you have changed the data source parameter to the name of the appropriate SQL Server name at your DA Site.
Adobe Acrobat Reader is available as a free download at the following website:

http://www.adobe.com/products/acrobat/readstep2.html
Form Status Types

The Special Services system will contain many different form types for potentially many years of data. To differentiate between these forms, form status types must be set up. These Status types will allow the user access to current and historical documents. Each document can contain up to 3 status types as defined below:

· Proposed – A new form currently in development by the evaluation team. These forms are only available to users with Edit/Create Security Roles.

· Current – The Finalized form currently in use by the School District. These forms are available to users with Read Security Roles.

· Archive – Any previous finalized form stored by the system. These forms are available to users with Read Archive Security Roles.

Only the staff that is entered into the MCSIS teachers table (TEAC) is currently in your ProgressBook’s district staff table.  All other staff must be entered using the Staff update feature in ProgressBook (i.e. Building Admin, Principals, Guidance, etc.).

Login Procedures 

There are 2 ways to log into the SpecialServices application. The first way is to click the SpecialServices link that displays from inside the ProgressBook application. The second method is to simply log directly into the SpecialServices application by navigating to the SpecialServices URL.

ProgressBook SpecialServices Login Procedure

This section explains how to log into the SpecialServices application through ProgressBook.

Progress Book is best viewed when using:

Internet Explorer 5.5 or later versions in Microsoft Windows Operating Systems

Internet Explorer 5.1.x or later versions in Macintosh Operating Systems

Safari in Macintosh OSX Operating Systems

Using Internet Explorer, enter the URL supplied by your School District, then click GO to the right of the Address bar.

[image: image1.png]Ele Edt View Favortes Toos Help

ok - = - D [0 4| Qserch (ravores Gvids 3|

ackvess | hitpfuman, <youDAste> orgfProgressgool]




After the Progress Book Login page loads:

· Type into the District ID: field.  Use the District ID that was given to you by your school district administrator.

· Enter your DSL User ID and DSL Password into the User ID: and Password: fields.

· Click “Login” button at the bottom of the screen.
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The picture shown below is the “Teacher Home Page” for ProgressBook.  The procedures detailed in this guide are for SpecialServices. Select the Special Services link at the top right of the screen to Log into the SpecialServices application,
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SpecialServices Stand Alone Login Procedure

This section explains how to log into the SpecialServices application as a stand alone system outside of ProgressBook.

Progress Book is best viewed when using:

Internet Explorer 5.5 or later versions in Microsoft Windows Operating Systems

Internet Explorer 5.1.x or later versions in Macintosh Operating Systems

Safari in Macintosh OSX Operating Systems

Using a web browser, enter the URL supplied by your School District, then click GO to the right of the Address bar.
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After the Progress Book Login page loads:

· Type into the District ID: field.  Use the District ID that was given to you by your school district administrator.

· Enter your DSL User ID and DSL Password into the User ID: and Password: fields.

· Click “Login” button at the bottom of the screen.
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· Required fields – If the user neglects to enter any required field, the application will notify the user of the field in error.
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Administrative Home Page

The picture shown below is the “Administration Home Page” for ProgressBook.  The procedures detailed in this guide are for Grade Levels and Special Services.
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Procedure for Navigating to Special Services Admin Home Page
The picture shown below is the “Special Services Home Page” for ProgressBook.  The following procedures refer to this home page.

· Click onto the link choice Admin Home.

· Special Services Home Page is now displayed.
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Procedure for Adding, Editing and Deleting Demographic Tags

You will have to add the Demographic Tag names you assigned to your PDF forms either while you are in the process of “tagging” your forms or after you’ve completed the process. 

· Successfully login to a district using an account that has administrative privileges.

· Navigate to Special Services Admin Home Page.

· Click onto the menu choice Demographic Field Generator.  The Demographic Tags Form is displayed.
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· When adding a new Demographic Tag scroll to the bottom of the Tag Names List grid. Click on “Add New Demographic Value” link. The grid opens up with a new row displaying empty textboxes to enter the new demographic tag information.  When all changes are made, click the “Save” button. “Cancel” aborts the add operation.
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Tag Name – The name property of the PDF Form field for the particular student demographic.

Tag Description – A longer description of the demographic tag.

Table Name – The database table name where the student demographic value is stored.

Field Name – The field name in the database table.

DB Connection – The name of the Demographic Database connection (See Setup Demographic Database Connection for details”).
· When editing a Demographic Tag, click on the edit column’s pin ( [image: image13.bmp] ) to the left of the Tag Name listed that you want to change.  The grid opens up and now permits editing of the demographic tag information.  Type into the fields that needs the changes.  When all changes are made, click the “Save” button. Clicking “Cancel” aborts the edit operation and reverts the information back to its original state.
· When deleting a Demographic tag, click on the red X next to the tag that you wish to remove from the Special Services system.
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Procedure for Assigning and Removing Security Roles

· Successfully login to a district using an account that has administrative privileges.

· Navigate to Special Services Admin Home Page.

· Click onto the menu choice Assign Security Roles.  The Security Roles form is displayed.
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· Select a Building from the “Select Building” drop down list.

· Select a Role from the “Role” drop down list.  See “Assign Security Levels” section for details on Roles.

· To assign roles to staff members click in the “Assign” columns check box for individual assignments.  Click the “Select All” button to assign the selected Role to all staff in the list. Click on “Submit Roles” to save the settings.  Remember, after making all your changes to this window, click onto the “Submit Roles” button at the bottom of this window to ensure the database has been updated.

· To remove roles from staff members click in the “Assign” columns check box for individual removals.  Click the “Deselect All” button to remove the selected Role to all staff in the list. Click on “Submit Roles” to save the settings.  Remember, after making all your changes to this window, click onto the “Submit Roles” button at the bottom of this window to ensure the database has been updated.  

Procedure for Assigning and Unassigning Security Levels

· Successfully login to a district using an account that has administrative privileges.

· Navigate to Special Services Admin Home Page.

· Click onto the menu choice Assign Security Levels.  The Security Levels form is displayed.
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· Select a Form Group from the “Group” drop down list.

· Select a Form Type from the “Form Type” drop down list.

· Select a Security Role from the “Security Role” drop down list.

· To add security privileges click on the “Add New Privilege” link. The grid opens up with a new row displaying a list box to choose the new Privilege.  When all changes are made, click the “Save” button.  “Cancel” aborts the add operation.
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· To remove security level privileges click on the “X” in the “Remove” column.  A dialog appears asking if you are sure you want to remove this privilege record.  Choosing “Yes” removes the privilege.

The default Staff role settings are:

	
	Level 100
	Level 200
	Level 300
	Level 350
	Level 400

	Read
	√
	√
	√
	
	√

	Archive
	√
	√
	√
	
	√

	Comment
	
	√
	√
	
	√

	Edit
	
	
	√
	
	√

	Finalize
	
	
	√
	
	√

	Create New
	
	
	√
	
	√

	Delete
	
	
	
	
	√

	Read EMIS
	
	
	
	√
	

	Edit EMIS
	
	
	
	√
	

	Finalize EMIS
	
	
	
	√
	

	Delete EMIS
	
	
	
	√
	

	Archive EMIS
	
	
	
	√
	


The default Parent Access role settings are:

	
	Level 10
	Level 20
	Level 30
	Level 400

	Read
	√
	√
	√
	√

	Archive
	
	√
	√
	√

	Comment
	
	
	√
	√

	Edit
	
	
	
	√

	Finalize
	
	
	
	√

	Create New
	
	
	
	√

	Delete
	
	
	
	√


Procedure for Assigning and Unassigning Parent Access Security Levels

· Successfully login to a district using an account that has administrative privileges.

· Navigate to Special Services Admin Home Page.

· Click onto the menu choice Assign Parent Access Security Levels.  The Security Levels form is displayed.
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· Select a Building from the “Select Building” drop down list.

· Select a User Type from the “Select User Type” drop down list.

· Select a Role from the “Select Role” drop down list.  See “Assign Security Levels” section for details on Roles.

· To assign roles to Parent Access users click in the “Assign” column’s check box for individual assignments.  Click the “Select All” button to assign the selected Role to all staff in the list. Click on “Submit Roles” to save the settings.  Remember, after making all your changes to this window, click onto the “Submit Roles” button at the bottom of this window to ensure the database has been updated.

· To remove roles from staff members click in the “Assign” columns check box for individual removals.  Click the “Deselect All” button to remove the selected Role to all staff in the list. Click on “Submit Roles” to save the settings.  Remember, after making all your changes to this window, click onto the “Submit Roles” button at the bottom of this window to ensure the database has been updated.  

How to Convert a Document to PDF

Converting files to PDF format requires you to have Adobe Acrobat Writer version 5.0 or higher installed on your machine.  

Method 1 – Print Command

In most applications you can use the Print command to create PDF documents by “printing” to the Adobe PDF printer. 

· Select Print from the application’s menu.  The application’s print dialog is displayed.  Select the Adobe PDF printer from the Printer Name list.
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· Click “Ok/Print” button.  The “Save As” dialog box displays and prompts you to enter a new file name.  Enter a new file name.  This name will be the name of your new PDF formatted document. 

Method 2 – Windows Explorer Right-Click on File

One of the easiest methods to create PDF documents from existing documents is to select a file or group of files in the Windows Explorer then right click.  Then choose “Convert to Adobe PDF”.
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Depending upon the type of file you are converting, either Acrobat or the source application opens and the file is converted to Adobe PDF.

Method 3 – Inside Adobe Acrobat

There are at least two ways to convert documents to PDF format using Adobe Acrobat Writer.  The first method is from Acrobat’s File menu.  The second is from Acrobat’s Task toolbar.  

· Select “Create PDF” from Adobe Acrobat’s File menu.  Then choose “From File…” on the submenu.  Then follow the file locator dialog to select a file to convert.
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· The second method is to click on [image: image22.png]T crestepoF -



 button from Acrobat’s Tasks Toolbar. 

How to Add Form Fields to PDF Documents

This section discusses adding form fields to PDF documents so “What You See is What You Get” (WYSIWYG) forms can be created and used to enter data.   Create a form field by choosing one of the form field tools, defining the area of the field on the Adobe PDF document page, and naming the field. For each field type, you can set a variety of options through the form field Properties dialog box. 

How to Create Form Fields

This section provides the steps for adding Form Fields to the document.

1. Open the Adobe Acrobat Writer.

2. Select a file to open. 

3. Acrobat displays the selected document.

4. Choose Tools> Advanced Editing> Forms> Show Forms Toolbar.

5. On the Forms Toolbar ([image: image23.png]‘v@u;‘




), select a forms tool.

6. Do one of the following:

a. Drag the cross-hair pointer to create a form field of the required size.

b. Double-click on the page to create a form field at that location using the default size. 

How to Access Form Field Properties

This section provides the steps for setting the most common properties of the form fields.

1. To select the form field, do one of the following:

a. Select the forms tool you used to create the form field that you want to change.

b. Choose Tools> Advanced Editing> Select Object tool [image: image24.png]E



.Do one of the following:

c. Drag the cross-hair pointer to create a form field of the required size (properties automatically display).

2. To access the form field’s properties box do one of the following:

a. Double-click the form field.

b. Right-click and select Properties.

c. Click the form field to select it, and then click the More button on the Properties toolbar to open the Properties dialog box.

[image: image25.wmf] The Properties toolbar contains only those settings that are most commonly changed.  To view the complete set of properties in the Properties dialog box, click the More button.

3. Click the General tab, and specify the following properties:

a. Enter a name (see Form Field Naming Conventions), tool tip text, and other general properties.

b. Select the Read Only option to prevent the field from being modified by the user.

[image: image26.wmf] To avoid accidental changes to the form field, select Locked in the lower left corner of the Properties dialog box.
4. Click the Appearance tab, and then specify the appearance properties.  The appearance properties determine how the form field looks on the page.  Remember, if you select a background color, you won’t be able to see through any graphics behind the form field.

5. Click the Actions tab, and specify any actions that you may want to associate with the form field, such as jumping to a specific page or displaying a media clip.  This option is used when adding “Save” and “Clear Form” buttons

6. Specify the remaining properties for your form field type, and click “Close”.

How to Set Default Properties for a Form Field Type

You can set a variety of properties for a form field, depending on the form field type. For example, the combo box and text form fields include format, validation, and calculation properties; however, these settings are not available for a check box form field. 

To save time when creating form fields, you can define default properties for a specific form field type, which you can then use as a template when you add another form field of the same type. For example, you can create a check box, specify all the properties, and save the properties as the default values for all check boxes. Then, the next check box you add to the form will have the same property values.

1. To select the form field, do one of the following:

a. Select the forms tool you used to create the form field that you want to change.

b. Choose Tools> Advanced Editing> Select Object tool.

2. Open the form field properties dialog box, and specify the settings.

3. Right-click (Windows) on the form field, and then select Use Current Properties as New Defaults.

4. Double-click on the page to create a form field using the default properties settings for that form field type.

How to Change Check Box Properties

Check boxes are the simplest form fields and they share the same General, Appearance, and Actions tabs as the other form field types. The Options tab contains a few simple properties that you can change to customize your check box form field.  Note: The size of the check inside the check box is determined by the size of the font you specify on the Appearance tab.
1. In the Check Box Properties dialog box, click the Options tab, and do any of the following options:

a. Select a check box style and whether you want the check box to be checked by default.

b. Enter an export value to represent the chosen item if it is exported to a CGI application. (See Defining CGI export values.)

2. Click Close to apply the selected property options.

How to Change Text Field Properties

Text fields can be set up to accept user input, to display text strings, and to allow multiple lines of text. You can also limit the number of characters a user can type into the field, and allow users to add text formatting.

Note: Some property settings are dependent on others. For example, you cannot check the spelling of a password field or a field used for file selection. These options appear unavailable. You must deselect the check spelling option before you can select the password or field used for file selection options.  (Spell checking can only be used if you have Adobe Writer.)

1. In the Text Field Properties dialog box, click the Options tab, and then do any of the following:

a. Select the text field alignment from the Alignment menu. This sets the alignment of text within the text box; it does not align the text box itself.

b. Type the default value text for the text field. You can leave the text box empty. You can also use the General tab to make the text box Read Only. (See How to Create Form Fields.)

c. Select Multi-line to allow for more than a single-line entry in the text field.

d. Select Scroll Long Text to compensate for text that extends beyond the boundaries of the text field.

e. Select Limit of Characters to set a limit to the number of characters that can be entered in the field.  Note: If you entered a default value, that value will be clipped to this limit.
f. Select Check Spelling to spell check the text entered by the user.

2. Click the Format tab, and choose a category type from the list. This specifies the type of data (numeric, date, time, and so on) the user can enter. For details, see Format options.

3. Click the Validate tab to run a custom validation script to establish that the text entered by the user is valid. For details, see Validation options.

4. Click the Calculate tab, and select the options if you want to perform mathematical operations. For details, see Calculation options.

5. Click Close.

Setting Field Tag Names:
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Format Options:

You can choose the format of data entered in text and combo box form fields from the Select Format Category menu, such as numbers, percentages, dates, and times.

In the Special category, you can select the format for zip codes, telephone numbers, and social security numbers. You can also use the Arbitrary Mask option to specify the types of characters the user can enter in any given position and how the data displays in the field. The following characters are used to specify the types of characters that can be entered:

· A-- Accepts only letters (A-Z, a-z).

· X-- Accepts spaces and most printable characters, including all characters available on a standard keyboard and ANSI characters in the ranges of: 32-126 and 128-255.

· O--The letter "O" accepts alphanumeric characters (A-Z, a-z, and 0-9).

· 9--Accepts only numeric characters (0-9).

For example, an arbitrary mask setting of AAA--p#999 accepts the input BOE--p#767. A mask setting of OOOOO@XXX accepts the input vad12@3Up.

[image: image28.png]Text Field Properties

General | Appearance | Options | Actions | Format [valdate | Calculte.

Select format atego [ spocl v

Special Options

2p Code.
2p Code + 4

Phane fumber

Social Security Nurber
Arbitrary Mask.

Jo00-4-000-AA

Use the Special formet category to set up custom
Formatting and to display phone numbers, 2ipjpostal
cads, and sacialsecurkty numbers

Cltocked





Arbitrary Mask option

The Custom format category lets you create new data formats and keystroke validation scripts with your own custom JavaScript. For example, you can define a new currency format or limit the entry to specific keystroke characters. To access the JavaScript Reference Guide for Acrobat, go to http://partners.adobe.com/asn/acrobat/index.jsp (English only) on the Adobe Web site.

Note: Select None from the menu if you do not want to specify any special form field formatting.

Validation options:

Use validation properties to restrict entries to specified ranges, values, or characters. This ensures that users enter the appropriate data for a specified form field. You can also use custom JavaScripts to define other types of validation, such as allowing only alphabetic entries in a form field. To access the JavaScript Reference Guide for Acrobat, go to http://partners.adobe.com/asn/acrobat/index.jsp (English only) on the Adobe Web site.

You can select from the following validation options:

· To turn off validation, select Field Value is Not Validated.

· To specify a numeric range for form fields using number or percentage formats, select Field Value is in Range.

· To run a JavaScript for custom validation, select Run Custom Validation Script.

ProgressBook Form Creation Requirements

This section explains how to create ProgressBook-specific forms.  

Optimizing PDF Form Files – AKA Removing PDF Bloat
Before getting too far into forms creation we need to let you know about an Adobe Acrobat problem creating ProgressBook/Special Service Forms.  As you create your forms in Adobe Acrobat Writer you will be saving and editing over and over until you get the form to look the way you want it to.  This edit/save process causes the document to “bloat” into a very large file.  The majority of the forms you create should be less than 500KB in size but no more than 1MB.  To reduce the file size, perform a File | Save As and give the file the same name to overwrite the existing very large file.  Another option is to click File | Reduce File Size and choose version compatibility.

You will want to check the file size before loading it into the Special Services system.

Form Field Naming Conventions

Position 1-3 defines the type of tags so the developers know where to go look for the data on the form.  It also tells the developers if it is a button; buttons are skipped when processing FDF.  

dem = Demographics on the Adobe Form

btn = Any buttons created on the Adobe Form

txt = All other data entry values on the Adobe Form 

hid = Hidden fields required on all Adobe Forms

chk = Check boxes on the Adobe Form

Ex.) demStudentLastName,  txtStudentGoal, btnSubmitForm, hidStudentID, chkVisionAbility

ProgressBook Forms Demographic Text Fields

Most forms created for use by ProgressBook will have specific demographic text fields.  These fields are pre-filled with demographic data from ProgressBook.  Demographic data includes fields such as Student Name, Parent Name, Student Address, Parent Address, DOB, School Name, etc.  The steps outlined in this section provide the steps for creating these demographic text fields.  

1. Follow the steps 1-4 in section “How to Create Form Fields”.

2. On the Forms toolbar, click on the Text Field Icon [image: image29.png]


.

3. On the General Tab set the Name property according to the naming convention in section “Form Field Naming Conventions”  ex) demStudentName, demMotherName, demStudentAddress, demDOB
ProgressBook Forms Required Hidden Text Fields

Every form created for use by ProgressBook will have specific hidden text fields that will indicate to the application the Form Name and Student ID. The steps outlined in this section provide the steps for creating these hidden text fields.  

4. Follow the steps 1-4 in section “How to Create Form Fields”.

5. On the Forms toolbar, click on the Text Field Icon [image: image30.png]


.

6. On the General Tab set the following properties:

a. Name = hidStudentID, hidFormID, hidPageNo for each Text Field.

b. Form Field = Hidden
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ProgressBook Forms Text Fields

All text fields that aren’t categorized as demographic or hidden fall into this category. The steps outlined in this section provide the steps for creating these “general” text fields.  

7. Follow the steps 1-4 in section “How to Create Form Fields”.

8. On the Forms toolbar, click on the Text Field Icon [image: image32.png]


.

9. On the General Tab set the Name property according to the naming convention in section “Form Field Naming Conventions”.  Ex.) txtMFE501cBackgroundInterviewComment, txtMFE501cDateOfPlan
ProgressBook Forms Required Buttons

Every form created for use by ProgressBook will have a “Save” and “Clear Form” button on it.  The steps outlined in this section provide the steps for creating these buttons.  Also, included in this section are instructions on adding a Benchmark Popup form button for forms requiring Benchmark and Indicator selections.
Adding a Save/Submit Button

The Save button tells the system to save the changes just made on the form.  “Save” changes back to the database.  At least one Save button must be on each form.  For multi page forms it’s probably a good idea to have one per page.

1. Follow the steps 1-4 in section “How to Create Form Fields”.

2. On the Forms toolbar, click on the Button Icon [image: image33.png]


.

3. On the General Tab set the Name property to btnSubmit.
4. On the Appearance Tab change the way the button appears on the form.  This step is optional and left to your discretion.

5. On the Options Tab change the Label property to Save.  This is the button that tells the system to save the changes to the form back to the database so it should be named accordingly.

6. On the Actions Tab set the following properties:

a. Select Trigger =  Mouse Down
b. Select Action = Submit a Form
c. Enter URL for this link = ../SaveForm.aspx#FDF
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7. Click the Add button to add the Trigger and Action to the Actions box.

8. Click on “Submit a form” displayed in the Actions box to select it.  This enables the Edit button.

9. Click on the Edit button to display the Submit Forms Selections properties box.  Set the following properties:

a. Enter a URL for this link = ../SaveForm.aspx#FDF
b. Field Selection = All fields
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10. Click OK to close the Submit Forms Selections properties box.

11. Click Close to close the Button Properties box.

Adding a Clear Form Button

This button is required on all forms that you allow to be cleared.  It removes all of the data entered into the fields on the form or from selected fields set in the “Select a Field to Reset” properties box.

.

1. Follow the steps 1-4 in section “How to Create Form Fields”.

2. On the Forms toolbar, click on the Button Icon [image: image36.png]


.

3. On the General Tab set the Name property to btnClear.
4. On the Appearance Tab change the way the button appears on the form.  This step is optional and left to your discretion.

5. On the Options Tab change the Label property to Clear.  (Clear Form, Clear Data).  

6. On the Actions Tab set the following properties:

a. Select Trigger = Mouse Down
b. Select Action = Reset a Form
7. Click the Add button to add the Trigger and Action to the Actions box.

8. Click on “Reset a form” displayed in the Actions box to select it.  This enables the Edit button.

9. Click on the Add button to display the Reset a Form properties box. 

10. Click the Select All button.  This selects all the form fields defined on the form.  Then remove the check mark from all of the fields starting with “dem” or “hid”.  These fields do not get reset.
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11. Click OK to close the Reset a Form properties box.

12. Click Close to close the Button Properties box.

Adding a Benchmarks Popup Form Button

This button is only necessary on forms that require the Benchmarks pop-up to retrieve Benchmarks and Indicators.

1. Follow the steps 1-4 in section “How to Create Form Fields”.

2. On the Forms toolbar, click on the Button Icon [image: image38.png]


.

3. On the General Tab set the Name property to btnBenchmark.
4. On the Appearance Tab change the way the button appears on the form.  This step is optional and left to your discretion.

5. On the Options Tab change the Label property to Get Benchmarks.  

6. On the Actions Tab set the following properties:

a. Select Trigger =  Mouse Down
b. Select Action = Submit a Form
c. Enter a URL for this link = ../SaveBenchmark.aspx#FDF
7. Click the Add button to add the Trigger and Action to the Actions box

8. Click on “Submit a form” displayed in the Actions box to select it.  This enables the Edit button.

9. Click on the Edit button to display the Submit Forms Selections properties box.  Set the following properties:

a. Enter a URL for this link = ../SaveBenchmark.aspx#FDF
b. Field Selection = All fields
10. Click OK to close the Submit Forms Selections properties box.

11. Click Close to close the Button Properties box.

Adding a Check Box

Many of the forms contain check boxes.  This is the procedure for adding checkboxes to your ProgressBook forms.

.

13. Follow the steps 1-4 in section “How to Create Form Fields”.

14. On the Forms toolbar, click on the Check Box Icon [image: image39.png]


.

15. On the General Tab set the Name property according to the naming conventions in section “Form Field Naming Conventions”.

16. On the Appearance Tab change the way the check box appears on the form.  This step is optional and left to your discretion.

17. On the Options Tab change the following properties:
a. Check Box Style = Check

b. Export Value = True/Yes
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PDF Forms Tips & Tricks

1. How can I get things to line up?

a. From the Advanced Editing Toolbar click on the Select Object Tool [image: image41.png]


.

b. Select the items you want to make the same size by ctrl-clicking or “lassoing” the group.

c. Right click and select “Align” and then the alignment method (right, left, top, bottom, horizontal, vertical).

2. How do I make form fields the same size?

a. From the Advanced Editing Toolbar click on the Select Object Tool [image: image42.png]


.

b. Select the items you want to make the same size by ctrl-clicking or “lassoing” the group.

c. Right click and select “Size” and then the size method (height, width, or both).

3. You can use the arrow keys to move the form fields around on the document.

4. Use Shift + arrow key to resize the form field in small increments.  It’s less frustrating than trying to use the mouse. 

5. Use Current Properties as New Defaults option doesn’t save the checkboxes export value default.  Go ahead and leave it set as Yes.  This involves less clicking.

6. To make a small change to the PDF document, you can use the Text Touch-Up or Object Touch-Up tools.  

7. To make larger changes, you may want to download a copy of the document in Word and make the changes, save changes, convert to PDF, then add the form fields.

8. What do I need to fill in here?

When in doubt, don’t add a form field.

9. What do I do with signatures and signature dates?

Don’t add form fields.

10. Standards for Buttons


Font = Arial


Font Size = 12


Font Color  = Blue for Save or Benchmark Lookup, Red for Clear Form

11. Tab order – done through the Navigation Bar on the left of the screen.  Not very flexible so we need to be careful about the order we add form fields to the document.

Textbox Properties’ Settings

	Tab
	Property
	Dem textboxes
	Txt textboxes
	Hid textboxes

	General
	Name
	dem<Field Name>
	txt<Field Name>
	hid<Field Name>

	
	Tool Tip 
	Optional
	Optional
	None

	
	Read Only
	Yes
	No
	Yes

	
	Form Field
	Visible
	Visible
	Hidden

	
	
	
	
	

	Appearance
	Font
	Times Roman
	Times Roman
	Times Roman

	
	Font Size
	12
	12
	12

	
	Text Color
	Blue (or your choice)
	Blue (or your choice)
	Doesn’t matter

	
	
	
	
	

	Options
	Multi-line
	Yes
	Yes
	

	
	Scroll
	No
	No
	

	
	Check Spelling
	No 
	Yes
	

	
	
	
	
	


Button Properties’ Settings

	Tab
	Property
	Submit
	Clear
	Benchmark

	General
	Name
	btnSubmit
	btnClear
	btnBenchmark

	
	Tool Tip 
	Optional
	Optional
	Optional

	
	Form Field
	Visible, doesn’t print
	Visible, doesn’t print
	Visible, doesn’t print

	
	
	
	
	

	Appearance
	Font
	Times Roman
	Times Roman
	Times Roman

	
	Font Size
	12
	12
	12

	
	Text Color
	Blue (or your choice)
	Red (or your choice)
	Blue (or your choice)

	
	
	
	
	

	Options
	Label
	Save
	Clear
	Benchmark

	
	
	
	
	

	Actions
	Trigger
	Mouse Up 
	Mouse Up
	Mouse Up

	
	Action
	Submit a Form
	Reset a Form
	Submit a Form

	
	URL Link
	../SaveForm.aspx#FDF
	---- 
	../SaveBenchmark.aspx#FDF


CheckBox Properties’ Settings

	Tab
	Property
	All Checkboxes

	General
	Name
	Chk<FieldName>

	
	Tool Tip 
	Optional

	
	Form Field
	Visible

	
	
	

	Appearance
	Border Color
	None

	
	Font Size
	Auto

	
	Fill Color 
	None

	
	
	

	Options
	Export Value
	Yes 

	
	
	


Please note:  Appearance property settings outlined in the tables above are only guidelines.  

Progress Book Administration Utility

Purpose

The Progress Book Utility is a Windows-based application that will help administer changes to the Special Services module, such as import PDF documents and save them to the database, link districts to forms, and set data sources to populate fields on the forms.  To close the application click File -> Exit.  To verify version number of the Progress Book Administration Utility, click Help -> About.

Note: Please use a minimum of 1024x768 resolution when using the utility.

Installing the Progress Book Administration Utility

To install the Progress Book Administration utility, simply download the ProgressBookAdminInstallation.msi file from the ProgressBook.com/Downloads site.  On the Web Server, download the file and double click the .MSI file.  You must provide the server name of the SQL Server used for Special Services.  Make sure that the installation is installed for Everyone.  Navigate to the location of where the application was installed to and open the configuration file, ProgressBookAdmin.exe.config, in a text editor, such as Notepad.  Make sure that the SQL Server name is located in the line <add key="server" value="yourservername" /> and that the pb_master table is located in the line <add key="database" value="pb_master" />. 

To start the application, either double-click the shortcut on the desktop or the ProgressBookAdmin.exe file in the directory that the Progress Book Administration Utility was installed in.

Adding districts to the Special Services Module

In the main menu, click Progress Book -> Districts to open the feature that will allow you to choose which districts will be affected by the Special Services application.  When the feature opens, the following screen will appear showing the available districts on the left-hand side and the chosen districts on the right-hand side.
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To quickly search for a particular district, type the district name in full or partially as a wildcard to filter the list.  Once the district has been found, click the checkbox in the Display column to enable that district.  Click the Update button and the district should appear in the right-hand pane.  To remove the district from the active list, simply uncheck the appropriate Display checkbox and click the Update button. 
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To close the Districts feature (and all of the features listed hereafter), click the second menu item and then Close.
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Adding Forms to Special Services

In the main menu that appears once the Progress Book Administration Utility loads contains a menu item, Special Services, which is used for maintaining the forms, types, groups, and miscellaneous changes.  Under the Special Services item, click Forms to add to or edit forms the Special Services module.  There are three types of forms that can be created and modified as listed below.
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District Forms

This type of form is specific to each school district using Special Services.

DA Site Forms

This type of form is used amongst the districts under each DA Site.

State Forms

This type of form is used state-wide as a standard set of forms for Special Services.

First, let’s start with the State Forms to help exemplify how to add edit form attributes for all three types of forms.  To view the list of available state forms, click the State Forms tab.  When a form record is clicked in the State Supplied Form Information window, the list of schools enabled (see Adding districts to the Special Services Module) will appear in the Districts window with two columns: Grant Access and Required.  Grant Access will allow that district the privilege to use the selected form and Required will force the selected form to be filled out and finalized for EMIS reporting.  If Grant Access is unchecked the district will not be allowed to have the form set to Required as well. 
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Importing PDF files into Special Services

To add an Adobe PDF file to the Special Services module, click on the File Name field of the State Form you with to update with a new file.  A pop up window will appear and ask for the location of the PDF file you wish to import.  After locating the file, click the Open button.  Any settings you made prior to the import will remain set, as long the form tags match.

[image: image49.png]Distict Forms | DA Site Foms State Forms |

State Supplied FormInformation

File Name.

Fam Type | StanDate |

Long Desciiption

Fom Nunber | Fom Source | Shor Descrlion |
o0 1 PRO
oo 1 P08 Aach
e 1 PROS
0 1 PROS
00 1 P06 PAGE 1
05 1 PRL08 PAGE 2

bl

Dislay Orcer | Tag Name

FR-08-Pg01 pcl
A

Pl Lookin
Pl
&l

»

3 chkBiLingualrSign anguagelnterpret
4 chkBiLingualrSign anguagelnterpret
5 chkEspedtedHeaingRequest

6 chkMediatiorServices

7 denBitday

s denDisabiyDescr

0 demPhanghlumber

11 demStudentAddress

1/6/2008

5 My Documents 5

« @ o B

Deskon

(£ My Documerts

2 My Computer
1 4 Flopay )

% My Fiecent Documents.

2D Die )
32 Shres on Domain Contoler/Eschange Fle
32 pbDammon on software-ansers comShre:
32 Common on sftwate-answers.coShares
32 Hatlanl$ on Santsnv0' ()

&3 My Network Places

(DF)Due Process REQUEST FOR AN IMPART
1
Locate Form to oad BE

File name: PR-08-Pg01 pdf

Di=
e
s





When selecting a form, the lower window Form Details will be populated with all of the attributes associated with the form tags.  After editing the fields for a form tag, click the Update button.  Below is a list and short description of each attribute for each form tag.

· Display Order – sequence order that the form tags will appear for the non-WYSIWYG mode

· Tag Name – the name of the form tag, e.g. chkMediationServices

· Description – the desription of the form tag that will be used in the non-WYSIWYG mode

· Spellcheck – enable (checked) or disable (unchecked) the spell check feature for this form tag

· Instance – the sequence number of a series of identical form tags

· Display Form – enable (checked) or disable (unchecked) whether the form will be displayed in SpecialServices

· Field Type – graphical user interface that will appear for the form tag, e.g. checkbox, textbox

· Export Value – value to enable the form tag (for checkboxes it should be YES)

· Lookup Entry type – the source of data (EMIS, text or XML)

· Lookup Group – List of Values (LOV) defined ??? as a source of data

· Append action – the method used to append all values of the form tags together for the EMIS flat file

· Lookup Export type - the destination of form data (EMIS, text or XML)

· Lookup Display type - List of Values (LOV) defined ??? as the display format of data

· Last Modified Date – non-editable field that display the date of last modification to the particular record

Adding Form Groups to Special Services
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To add form groups to the Special Services module, click Special Services -> Forms Data Administration -> Groups.  When the Current Groups section appears, click the last box available to add a group.  To edit existing groups, simply click the textbox that they appear in and make the appropriate changes.
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Adding Form Types to Special Services

To grant districts access to a particular form type, such as IEP or Evaluation, click Special Services -> Forms Data Administration -> Types.  When the Types window appears on the left-hand side, click the last box available to add a group.  To edit existing groups, simply click the textbox that they appear in and make the appropriate changes.

The Districts Associated with Selected Type window will show all enabled districts that have been granted access to the selected form type.  To add a new district, simply click the district record and the < button;  the > button will remove a selected district; the >> button will remove all districts; the << button will add all districts.
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Miscellaneous Administration to Special Services

Under Miscellaneous Administration, you can customize how the data from the forms will be displayed and stored, as well as how the values of lookup groups and codes will be set.   To set the display types, click Special Services -> Misc Administration -> Display Type.  Setting up this feature is very similar to the Form Groups section.
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To edit the existing display types, simply click on the record and make the changes.  Click Update to save the changes.  To add a new display type, click on the last empty textbox and type the new display type.
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To define the delimiters that will be set for EMIS files, click Special Services -> Misc Administration -> Append.  Provide a simple description that will appear to identify the type of delimiter, the character delimited, and the type of action used to append subsequent data.
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The lookup administration is used to define the data sets used to populate drop down menus for the form tags in the Forms Detail window of the Forms menu item (see Importing PDF files into Special Services).  The left-hand window displays the available groups and attributes defined with each group.  To add a new group, simply click on the last available textbox and provide the appropriate information to define the lookup group.  There are three attributes for each lookup group: Description, Data Populator (stored procedure to add lookup values) and Data Source (location of where lookup values originate).  If the Data Source is set to None, then an empty ??? is created to allow shared access to the values contained for that group.  This type of data source is typically used for customized goals that need to be available across multiple forms or reports.
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After clicking on an existing group, the middle window may populate with any values associated with the group and the Default Value checkbox will be checked for the value that will appear when the drop down field is shown on a form.  The right-hand window displays a list of all available look up values.  If you wish to add a value to the group, click the record of that value and the < button to populate the Associated Groups and Lookup Values window.  The > button removes the selected value from the list; the >> button removes all values; the << add all available values to the list.  The available look up values contain 2 attributes: description (label that appears in the drop down) and code (value associated with the code).  These two values can be displayed, depending on how you have set up the display values (e.g. LovDescLovCode).

Overriding Administrative Settings

This feature is for Software Answers, Inc. support personnel only when a change needs to be made to a critical value.  A password is needed to set the application to an administrative override mode to assist in making changes to a database constraint or critical value.

 .

Removing Finalized Forms From Special Services

If any finalized forms need to be removed from the Special Services application, they must be removed through SQL Server.  The following are the steps necessary to remove the forms.  We strongly suggest backing up your database before proceeding.

· Open Query Analyzer and choose the correct district database to make the changes.

· Type in the following code to retrieve the student’s student_dbid that needs the finalized forms deleted (formstatus_dbid of 2 means Current and 3 means Archived):

--determine student_DBID to delete from this query.

Select * from student where lastname = ‘XXX’ and firstname = ‘XXX’

· With the student_Dbid (e.g. XXX) find all Current and Archived forms for that student:

select * from studentforms where student_DBID=XXX and formstatus_DBID in(2,3)

· With the studentform_dbid number (e.g. YYY), type in the following statements to remove the records:

--Delete sequence.

DELETE FROM spsStudentSelectedLOV where studentform_DBID=YYY

DELETE FROM studentformcomments where studentform_DBID=YYY

DELETE FROM studentformdetails where studentform_DBID=YYY

DELETE FROM studentforms where studentform_DBID=YYY 

· Using the student_dbid (e.g. XXX) and the studentform_dbid (e.g. YYY) from above find the studentfinalizedgroup_dbid (e.g. ZZZ):

--Determine the Finalized details to delete from this query.

SELECT     spsstudentfinalizedgroups.spsStudentFinalizedGroups_DBid, FormGroupName

FROM         spsStudentFinalizedGroups INNER JOIN

                      spsStudentFinalizedGroupForms ON 

                      spsStudentFinalizedGroups.spsStudentFinalizedGroups_DBID = 

spsStudentFinalizedGroupForms.spsStudentFinalizedGroups_DBID

WHERE     (spsStudentFinalizedGroups.Student_DBID = XXX) AND 

(spsStudentFinalizedGroupForms.spsStudentForms_DBID =YYY)

· Complete the delete:

--Delete Sequence

DELETE FROM spsStudentFinalizedSelectedLov where spsStudentFinalizedGroups_DBid=ZZZ

DELETE FROM spsStudentFinalizedformimages where spsStudentFinalizedGroups_DBid=ZZZ

DELETE FROM spsStudentFinalizedgroupforms where spsStudentFinalizedGroups_DBid=ZZZ

DELETE FROM spsStudentFinalizedgroupdetails where spsStudentFinalizedGroups_DBid=ZZZ

DELETE FROM spsStudentFinalizedgroups where spsStudentFinalizedGroups_DBid=ZZZ

· The finalized and archived forms should be deleted from the system.  Login and verify the results.
Form Wizard Setup
The following steps outline the setup necessary in each Adobe document as well as the values that need set to ensure the Form Wizard Editor is properly setup.

Adobe Setup

Ensure the Advance Editing Toolbar is displayed from Adobe Acrobat Professional.
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PDF Setup – Character Length

The Non-WYSIWYG (or Forms Wizard) system requires special settings such as Number of Characters to ensure the Forms Wizard will work properly. Every text box on the PDF form will need the Max Character value set otherwise; the system will assume a default of 100 characters for single line textboxes and 255 characters for multi-line text boxes.
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PDF Setup – Check Boxes

The Non-WYSIWYG (or Forms Wizard) system requires special settings for the checkboxes that are used on the State Standard forms to ensure the Forms Wizard will work properly. The export value for each check box must be noted and inserted into the proper row on the Form Wizard Editor of Form Maintenance Utility.
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Currently, ActivePDF does not pull this value automatically. Therefore the Export Value must be manually inputted for each check box on a form.
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To Edit, Click in the appropriate row and type in the export value exactly as displayed from the pdf. 
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PDF Setup – Special Buttons

The Non-WYSIWYG (or Forms Wizard) system requires special settings for Buttons that are used on the State Standard forms to ensure the Forms Wizard will work properly. The Special Buttons currently used is limited to the “Get Benchmarks” Button displayed  on the PR-07 Steps 3-6.
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In order to enable this feature on the Form Wizard side of the application, One must Instruct the application to use the same ASPX page that the button represents. To complete this; ensure the Type of the field is set to button and enter in the name of the ASPX page in the Export Value column of the Form Wizard Editor.  In this case the name of the Popup window is “ViewIndicators.aspx”.
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Standalone Application Setup and Maintenance

In order for the application to run in a stand alone state away from the ProgressBook application, some setup and integration with DSL is required. If a District is running ProgressBook, then this section is not necessary.

Update database

Copy the latest version of the ProgressBook Special Services database from the Downloads site and install.

Format and Clean Database tables

If the database currently exists for a district but has not been used, extract and run the bcpin_sped.cmd found inside the SpecialEdIn.zip file. This cmd file will clean out any unused forms and prepare the database for the loading of the new special ed forms.

Upload new forms

Using the instructions noted above for the Form Maintenance Utility, copy the latest version of the Special Ed forms out to the newly created database.

Link SQL Databases

If your system maintains the DSL database on one server and the ProgressBook Special Education system on another SQL server, Link the 2 servers together so the data share may take place. 
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Enter the specific DSL server name to link from the ProgressBook Database Server.
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Setup School table

Manually enter the proper school building information for the available schools within the school district through enterprise manager.
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Setup Grade Levels

Manually setup the grade levels for the specific school district by executing the PopulateGradeLevelsFromDSL.sql file from inside Query Analyzer. Make sure to replace the server name in the query with the actual name of the DSL SQL server linked in the steps above.
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Setup SQL Scripts for Nightly Integration

Copy the PopulateTeacFromDSL.sql and the PopulateStudFromDSL.sql from the Downloads site. Open each .SQL file and modify the DSL Server name appropriately.
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And
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 Create the proper .CMD files for each off of the RunSQLScript.vbs file.

Schedule Nightly Task

The nightly task scheduler can be found under the Control Panel in Windows. Schedule the integration tasks PopulateTeacFromDSL.cmd and PopulateStudFromDSL.cmd to run at appropriate times on your server. The suggested task schedule is nightly, after the database backup has been completed. This ensures the data accurately represents the following day’s data. 
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